List of required packages to build the X server from git.

(Please add your distribution if it is missing)

Ubuntu

Oneiric Ocelot 11.10

Swipe the following command to install all required packages. About 900MB of additional storage is required.

sudo apt-get install asciidoc autoconf automake autopoint autotools-dev  bison docbook-utils doxygen flex fop git-core  gperf intltool jadetex libdrm-dev libfontconfig1-dev libfreetype6-dev libgbm-dev libglib2.0-dev libmtdev-dev libncurses5-dev libpng12-dev libssl-dev libtool libudev-dev llvm m4  netpbm psutils systemtap-sdt-dev w3m xmlto  zlib1g-dev
asciidoc                8.6.4
autoconf                2.68
automake                1.11.1
autopint
autotools-dev           20110511
bison                   2.4.1
docbook-utils           0.6.14
doxygen                 1.7.4
flex                    2.5.35
fontconfig              2.8.0   pre-installed
fop                     0.95
gcc                     4.6.1   pre-installed
gettext                 0.18.1  pre-installed
gettext-base            0.18.1  pre-installed
ghostscript             9.04    pre-installed
git-core                1.7.5.4
gperf                   3.0.3
intltool                0.41.1
jadetex                 3.13
libgbm-dev
libfontconfig1-dev      2.8.0
libfreetype6            2.4.4   pre-installed
libfreetype6-dev        2.4.4
libglib2.0-dev          2.30.0
libmtdev-dev
libncurses5-dev         5.9
libpng12-0              1.2.46  pre-installed
libpng12-dev            1.2.46
libssl-dev              1.0.0e
libtool                 2.4
libudev-dev
llvm                    2.8
m4                      1.4.16
netpbm                  10.0
openssl                 1.0.0e  pre-installed
perl                    5.12.4  pre-installed
pkg-config              0.26    pre-installed
psutils                 1.17
systemtap-sdt-dev       1.4
w3m                     0.5.3
xmlto                   0.0.23
zlib1g                  1.2.3.4 pre-installed
zlib1g-dev              1.2.3.4

Gentoo

stage3-amd64-20100514.tar.bz2

Had to install:

docbook-xml-dtd         4.1.2
docbook-xml-dtd         4.3
docbook-xml-dtd         4.4
doxygen
gd (USE: jpeg png)
git
gperf
freetype
intltool
libxlst
lynx (or w3m)
pkgconfig
xmlto

OpenSolaris

2009.06

There are multiple versions for aclocal, automake, and python. You need to create links to the latest version in $prefix/bin.
SUNWaconf               2.61
SUNWgnu-automake-110    1.10
SUNWbison               2.3
SUNWgnome-xml           0.6.3
SUNWdoxygen             1.5.7.1
SUNWflexlex             2.5.33
SUNWfontconfig          2.5.0 pre-installed
SUNWgcc                 3.4.3
gcc-dev                 3.4.3
SUNWgmake               3.81
SUNWgnome-common-devel  0.5.11
SUNWgnu-gettext         0.16.1
SUNWgit                 1.5.6.5
SUNWgperf               3.0.3
SUNWgroff               1.19.2
SUNWncurses             0.5.11
SUNWpng                 0.5.11
SUNWopenssl             0.9.8 pre-installed
SUNWlibtool             1.5.22
SUNWgm4                 1.4.2
SUNWperl*               5.8.4
SUNWPython26            2.6.1
SUNWpython-lxml         2.1.2
SUNWzlib                1.2.3

OpenBSD

pkg_add the following packages

automake-1.9
autoconf-2.62
libtool
metaauto

Packages needed to reformat docs need to be sorted out...

Set environment variables to point to the autotools version you're using

PKG_CONFIG_LIBDIR=/usr/X11R6/lib/pkgconfig
AUTOMAKE_VERSION=1.9
AUTOCONF_VERSION=2.62
ACLOCAL="aclocal -I /usr/X11R6/share/aclocal"

openSUSE

11.3

The libtalloc-devel package for openSUSE 11.3 is missing the required talloc.pc file to allow the mesa build to complete successfully. There are two ways this can be fixed:

  1. defining environment variables which work with pkg-config:
     $> export TALLOC_LIBS=-ltalloc
    $> export TALLOC_CFLAGS="-I/usr/include"
    $> build.sh -o mesa/mesa $PREFIX
    
  2. installing a fixed, updated libtalloc-devel package. See https://bugzilla.novell.com/show_bug.cgi?id=632770 for details. NOTE: openSUSE 11.2 also seems to have this problem