Before you start

For 6xx/7xx 2D acceleration, you don't need to use a branch of radeonhd any more - standard, released version 1.2.5 is enough.

You still need correct version of drm (kernel) driver. You can just install 2.6.30 kernel, or the Ubuntu Jaunty default kernel, or use following instruction for that. The alternative driver, radeon, can also utilize the same drm branch for the same features.

Current status is :

  • It should provide EXA acceleration, Xv acceleration.
  • AGP support has been recently added
  • Corruption problems believed to be fixed
  • Hanging on VT switch believed to be fixed
  • r6xx-r7xx-support branch were merged into master for both radeonhd and radeon
  • You must use drm code from r6xx-7xx branch of mesa drm or 2.6.30 kernel, or an older kernel (eg. Jaunty) with backported support.

How to build drm from r6xx-7xx branch of mesa drm

  • checkout the source for the drm:
   git clone git://
  • switch drm to the experimental branch and build its modules :
   cd drm/linux-core
   git checkout -b r6xx-r7xx-support origin/r6xx-r7xx-support
   make radeon.o drm.o
   find /lib/modules -name "radeon.ko" -o -name "drm.ko"
   sudo cp radeon.ko /lib/modules/$(uname -r)/.../radeon.ko
   sudo cp drm.ko /lib/modules/$(uname -r)/.../drm.ko

This last path will likely depend upon your linux distribution.

How to enable EXA and Xv

  • configure your xorg.conf ; you need at least two options in the Device section :
        Option      "AccelMethod" "exa" # default shadowfb
        Option      "DRI" "on"